Skip to content

etcd: Nonblocking Lua etcd driver library for nginx-module-lua

Installation

If you haven't set up RPM repository subscription, sign up. Then you can proceed with the following steps.

CentOS/RHEL 6, 7, 8 or Amazon Linux 2

yum -y install https://extras.getpagespeed.com/release-latest.rpm
yum -y install lua-resty-etcd

To use this Lua library with NGINX, ensure that nginx-module-lua is installed.

This document describes lua-resty-etcd v1.6.0 released on Oct 11 2021.


resty-etcd Nonblocking Lua etcd driver library for OpenResty, this module supports etcd API v2 and v3.

License

GitHub

You may find additional configuration tips and documentation for this module in the GitHub repository for nginx-module-etcd.

Back to top